关于jsdom的版本问题
发布于 5 年前 作者 scorpio 3528 次浏览 最后一次编辑是 1 年前

最近想用nodejs来做网页抓取,选中了jsdom,但是安装过程成发现失败了 我想询问下,jsdom对nodejs,npm的版本有要求吗? jsdom版本有要求吗? 谢谢 http://stackoverflow.com/questions/10143288/node-js-jsdom-error这是网上的一份资料,但是不知道对不对

3 回复
node.js:201
    throw e; // process.nextTick error, or 'error' event on first tick
          ^

TypeError: Cannot read property ‘implementation’ of undefined at /home/scorpio/nodejs/node_modules/jsdom/lib/jsdom.js:171:59 at Object.env (/home/scorpio/nodejs/node_modules/jsdom/lib/jsdom.js:262:5) at Object.<anonymous> (/home/scorpio/nodejs/1.js:3:7) at Module._compile (module.js:441:26) at Object…js (module.js:459:10) at Module.load (module.js:348:31) at Function._load (module.js:308:12) at Array.0 (module.js:479:10) at EventEmitter._tickCallback (node.js:192:40) 官网那个例子报错。。。

没遇到这个问题呃

win7安装报错,

回到顶部