node-webkit require问题...
发布于 3 年前 作者 scorpio 2072 次浏览 最后一次编辑是 8 个月前

我又来了… 貌似客户端js在node里面是不能require的… 但是node-webkit的客户端js是能require的… 那这样的话,node-webkit应该怎么调试…

2 回复

你想说啥? 如果你把浏览器端的JS代码放到node-webkit 去,浏览器没有require那你担心node-webkit有require做什么? 如果你要把node-webkit 的js放到浏览器端去,要么自己去模拟require(mocha就是这么做的),要么重写JS。 至于调试没发现node-webkit和Chrome有多大区别…

node-webkit 就是基于 chromium 编译的。 其实真的没法有多大区别

回到顶部