node install ffi报错,大神们,求解答
发布于 7 天前 作者 zhangrss 421 次浏览 来自 问答

2017-11-13 16:23:01.601 xcodebuild[24568:190947] [MT] PluginLoading: Required plug-in compatibility UUID DFFB3951-EB0A-4C09-9DAC-5F2D28CC839C for plug-in at path ‘~/Library/Application Support/Developer/Shared/Xcode/Plug-ins/VVDocumenter-Xcode.xcplugin’ not present in DVTPlugInCompatibilityUUIDs CC(target) Release/obj.target/ffi/deps/libffi/src/prep_cif.o CC(target) Release/obj.target/ffi/deps/libffi/src/types.o CC(target) Release/obj.target/ffi/deps/libffi/src/raw_api.o CC(target) Release/obj.target/ffi/deps/libffi/src/java_raw_api.o CC(target) Release/obj.target/ffi/deps/libffi/src/closures.o CC(target) Release/obj.target/ffi/deps/libffi/src/x86/ffi.o CC(target) Release/obj.target/ffi/deps/libffi/src/x86/ffi64.o CC(target) Release/obj.target/ffi/deps/libffi/src/x86/darwin.o CC(target) Release/obj.target/ffi/deps/libffi/src/x86/darwin64.o LIBTOOL-STATIC Release/libffi.a libtool: unrecognized option -static' libtool: Trylibtool --help’ for more information. make: *** [Release/libffi.a] Error 1

2 回复

你用的是node 几版本?node v8.9.1吗? 推荐最新使用《node v8.9.0》。我昨天晚上,在node v8.9.1上安装node-java模块时,也报编译错误了。然后,换node v8.9.0就没有问题了。

回到顶部