关于npm install socket.io出现错误
发布于 8 年前 作者 leezhm 9511 次浏览 最后一次编辑是 4 年前

如果在安装socket.io的时候,出现一下错误

> ws[@0](/user/0).4.0 preinstall /home/shoan/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
> make

node-waf configure build
Traceback (most recent call last):
  File "/usr/bin/node-waf", line 14, in
  import Scripting
  File "/usr/bin/../lib/node/wafadmin/Scripting.py", line 146
except Utils.WafError, e:
                     ^
SyntaxError: invalid syntax

应该是你系统中安装的python的版本是3.0以上,请修改降级版本到2.7。

然后npm cache clean清空缓存,再次npm istall socket.io安装应该就可以成功!

1 回复

再试一遍可能就好了

回到顶部