express.js的多版本共存?
发布于 8 年前 作者 ruisin 3951 次浏览 最后一次编辑是 4 年前

想测试一下express.js的3.0版本 但是如果直接安装,npm install -g express[@3](/user/3).0 这样的命令,旧版本的express不就是被覆盖掉了嘛?看了一下几个node的多版本共存项目,都没有像rvm一样在同样的版本中还有set的概念,像express这样有可执行命令的包,如何管理多版本的共存呢?

3 回复

软件会优先调用node_module吧?

我指的是 用 -g 参数全局安装 就只能装特定版本的了

@ruisin 如果是全局,好像只能有1个Express? 但是你可以每个项目选用不同的Express.

回到顶部