在webstorm里创建了node 工程,用npm install 命令安装的模块,为啥run的按钮一直是暗的? nodejs路径已经设置了。
发布于 8 年前 作者 zhangking 49730 次浏览 最后一次编辑是 5 年前
14 回复

webstorm没什么人用吧…

要启用Node.js vx.x.x Core Modules

Settings > JavaScripts > Libraries

除了设置webstorm的nodejs还要针对你的项目添加一个配置,告诉webstrom你的项目属于Nodejs,在run菜单里有一个editconfigurations 选择添加,类型选择nodejs,然后填一下appjs的路径

control + shift + s 找到那个library 的选项,把node 添加进来…

怎么会呢,我还买了正版的…前段时间osc搞了个活动…

@youxiachai 果然是这个3折…

请问一下, 我用webstorm新建了node工程之后, 在package.json文件中新添加了依赖模块, 我现在都是在黑窗口中输入npm install命令来加载新添加的依赖模块的, 我想知道在webstorm中能不能直接install.

请问一下, 我用webstorm新建了node工程之后, 在package.json文件中新添加了依赖模块, 我现在都是在黑窗口中输入npm install命令来加载新添加的依赖模块的, 我想知道在webstorm中能不能直接install.

Settings -> Project Settings -> JavaScript -> Node.js -> Packages -> Install

@sxd1140

点开node.js这一步, 就没看到 Packages 了… 望继续指导

以前用webstorm的时候是有的 后来用idea 12 后 发现 只有上面2个 node路径 和 源码路径 后来用idea 13后 才变为和webstorm一样 有第三个Packages区域

也许是webstorm版本问题吧

@seasonx4。=。=!~其实我觉得那个IDE 不好用~可能我用不习惯吧。

@rouge 安装commond line support插件,ctrl+shift+x调用,设置一下就可以使用node、npm命令了

回到顶部