windows下安装session-mongoose有错误,难道需要安装visual studio?
发布于 11 年前 作者 hunk 5888 次浏览 最后一次编辑是 8 年前

npm install session-mongoose

F:\workspace\nodejs-demo\node_modules\session-mongoose\node_modules\mongoose\nod e_modules\mongodb\node_modules\kerberos>node “C:\Program Files\nodejs\node_modul es\npm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild MSBUILD : error MSB3428: 未能加载 Visual C++ 组件“VCBuild.exe”。要解决此问题,

  1. 安装 .NET Fram ework 2.0 SDK;2) 安装 Microsoft Visual Studio 2005;或 3) 如果将该组件安装到了 其他位置,请将其位置添加到系统 路径中。 [F:\workspace\nodejs-demo\node_modules\session-mongoose\node_modules\mo ngo ose\node_modules\mongodb\node_modules\kerberos\build\binding.sln]

bson@0.2.2 install F:\workspace\nodejs-demo\node_modules\session-mongoose\node _modules\mongoose\node_modules\mongodb\node_modules\bson (node-gyp rebuild 2> builderror.log) || (exit 0)

F:\workspace\nodejs-demo\node_modules\session-mongoose\node_modules\mongoose\nod e_modules\mongodb\node_modules\bson>node “C:\Program Files\nodejs\node_modules\n pm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild MSBUILD : error MSB3428: 未能加载 Visual C++ 组件“VCBuild.exe”。要解决此问题,

  1. 安装 .NET Fram ework 2.0 SDK;2) 安装 Microsoft Visual Studio 2005;或 3) 如果将该组件安装到了 其他位置,请将其位置添加到系统 路径中。 [F:\workspace\nodejs-demo\node_modules\session-mongoose\node_modules\mo ngo ose\node_modules\mongodb\node_modules\bson\build\binding.sln]
4 回复

应该需要编译

这个问题有人解决么? 高手们

这个问题有人解决么? 高手们 顶上去,直至解决为止,windows下vs依赖编译环境引起的npm各种安装各种报错问题。

我想问下这个问题是不是安装vs2005以上的版本就可以解决??

回到顶部