npm install sqlite 怎么提示'node-waf' 不是内部或外部命令,也不是可运行的程序,不是说在node9.1就没有node-waf这个命令吗
发布于 7 年前 作者 earthwormqiu 7847 次浏览 最后一次编辑是 5 年前

E:\project\bee>npm install sqlite npm http GET https://registry.npmjs.org/sqlite npm http 304 https://registry.npmjs.org/sqlite

sqlite@1.0.4 preinstall E:\project\mytm1\node_modules\sqlite node-waf configure build

‘node-waf’ 不是内部或外部命令,也不是可运行的程序 或批处理文件。 npm ERR! weird error 1 npm ERR! not ok code 0

不是说node0…9.1 移除了node-waf,使用node-gyp代替 这个需要我自己去修改这个sqlite这个node_modules?

4 回复

… 你应该去下载

npm install sqilte3 ..

sqlite …作者早就弃了…

sqlite3 才是你的选择…非常不错的库,还做了pre-gyp 这个牛逼的功能.

话说…下载包之前…不上npm 先看一下…吗…

好久没来看了,是的我现在用sqlite3了,但是实在centos下 谢谢youxiachai 3楼

回到顶部