一个安装pm2时候发现的问题,详见正文
发布于 6 年前 作者 shuson 13639 次浏览 最后一次编辑是 4 年前

npm ERR! notsup Not compatible with your operating system or architecture: pm2@0.8.11 npm ERR! notsup Valid OS: !win32 npm ERR! notsup Valid Arch: any npm ERR! notsup Actual OS: win32 npm ERR! notsup Actual Arch: x64

win7 64位 旗舰版

求解答

经讨论已解决: pm2 不支持win系统

8 回复

感谢,,呃,,,我在国外留学呢,英语。。。

pm2好像不支持windows系统,你要用linux或者mac才行。

非常感谢,我这注意力,,,以为是我电脑问题呢。 再问一句,node_club_dev源码,当部署本地是win系统的时候,npm install也应该会安装pm2吧?这时候怎么办

会安装,但是不成功而已,所以你在配置文件里面移除pm2。

package.json文件移除这里面的pm2信息
  "dependencies": {
  },

最终我在虚拟机里搞了,node还是喜欢linux

还是linux上比较好开发

学习了,我安装nodeclub各种出错… win xp伤不起

回到顶部