Node.js初学者求教~~大家都在用Express什么版本?
发布于 10 年前 作者 runrune 8755 次浏览 最后一次编辑是 8 年前

话说Express3.x 跟 Express4.x 的变动也真大啊~~ Express4 的中间件全被独立出来,很多网上的Express3代码都没法用,真是操蛋啊~~

该用哪个版本呢?

是这样,有个PHP做的网站,需要实现实时聊天功能,准备用socket.io + express 做,现在安装的是Express4版本,需要用到 session 功能,可发现网上大多数代码都还是Express3版本的~~

理论上 Express4 版本应该架构更好,可要如何实现跟 socket.io 的session 连接呢? 一头雾水啊~~求大牛赐教,谢谢~~

8 回复

开始入门的时候,就学的3.x,现在也一直在用3.x,等什么时候有时间了,再去研究研究4.x。 我的建议:用3.x。因为教程多,用的人也最多,出现问题,容易解决。

官方文档有,中间件独立了,session有中间件express-session。

@haiyang5253 尴尬了,我装了个4.0在MAC上。

一开始 不建议学框架,

用4.2.0(目前最新版)的飘过

@wteam-xq3 4.2.0 只是 express generator 的版本, express 的最新版本应该 4.7.* 了吧

@Lee2011 哦, 还以为是最新版呢, 我错了。

回到顶部