Win 7 下npm命令失败,无法安装任何模块。NPM最新的session-mongoose有问题吗?
发布于 6 年前 作者 huazhenhz 6135 次浏览 最后一次编辑是 4 年前 来自 问答

如下图所示,不知是何原因,该如何处置? 多谢!

npm_error.png

3 回复

是不是NPM的session-mongoose有问题,不能用? 为什么还会影响到其它模块的安装? 哪怕是我利用npm安装nodemailer、mathjs这样与mongodb毫无关系的模块,一样会出现上面的错误。

应该找到问题了。 这个session-mongoose目前尚不支持最新版本的connect和express。 当时没仔细看npm下的说明。 session-mongoose.png

将磁盘上…\npm\nodemodules\目录下的session-mongoose目录删除后,其它模块就可以通过npm正常安装了。

回到顶部