安装React Native出现的WARN unmet dependency
发布于 4 年前 作者 weiheli 9383 次浏览 最后一次编辑是 3 年前 来自 问答

安装React Native时,出现下面的WARN

/usr/local/bin/react-native -> /usr/local/lib/node_modules/react-native-cli/index.js
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/read-installed/node_modules/readdir-scoped-modules requires graceful-fs@'^4.1.2' but will load
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/read-installed/node_modules/graceful-fs,
npm WARN unmet dependency which is version 3.0.8
react-native-cli@0.1.4 /usr/local/lib/node_modules/react-native-cli
└── prompt@0.2.14 (revalidator@0.1.8, pkginfo@0.3.0, read@1.0.7, winston@0.8.3, utile@0.2.1)

请问是缺少npm包吗? 我又执行了sudo npm install -g graceful-fs,还是不行

6 回复

已解决

@weiheli 如何解决的呢?

@weiheli 同问,我记得意思是不匹配的依赖,但是我也不知道什么原因

来自炫酷的 CNodeMD 越来越喜欢material design😁

WARN 可以不搭理的。

@jaywcjlove @XGHeaven 时间很久了,我都忘了。 记得是 graceful-fs 版本太低的问题,根据提示,安装graceful-fs@'^4.1.2'

@weiheli 我已经搞定了,我 更新了npm 和nodejs

回到顶部