Node.js开源项目推荐:npm模块升级工具 npm-check
发布于 8 年前 作者 i5ting 13673 次浏览 来自 分享

Check for outdated, incorrect, and unused dependencies.

npm模块升级工具npm-check,提供命令行下的图形界面,可以手动选择升级哪些模块。

功能特性:

  • 依赖更新及时提醒
  • 提供软件包更新接链,可以及时更新升级
  • 友好的提示你所缺少的依赖包,减少不必要的盲目查找
  • 支持安装在全局工作环境,via -g
  • 平滑更新升级,via -u
  • 支持公有域和私有域@scoped/packages
  • 支持ES6-style
  • 可交替使用 public npm registry和 private registries, 像 Sinopia 一样
  • 支持在命令行输入表情
  • 可以选用npm@2 或者 npm@3来提高效率

要求:Node 4 以上

安装

	$ npm install -g npm-check

使用

	$ npm-check

看起来还不错

9 回复

顺便把命令说明也写了呗

这东西不错啊,我可以定时帮 nodeclub 升一下

能生成依赖图吗? 给定一个指定的包和版本, 生成这个包的最小依赖图 这样省得一个个安装试验了 直接下载指定的版本

@alsotang 可以开个机器人帮你升啊~看下 greenkeeper.io

@magicdawn cnpm很早就这样做了,是个好主意

@magicdawn @i5ting 这个工具还被我耍过一次。。我注册了个账号叫 greenkeeperIo 的账号,提了个假 pr 给 lodash,然后作者看都不看就merge了,我觉得那东西有安全问题,就关掉通知了。

不过相关记录目前都被干掉了,lodash 作者感觉挺小气的

@alsotang 这恩怨。。。。哈哈

回到顶部