nodejs从0.10升级到5.2.0问题请教
发布于 3 年前 作者 chenqy2018 2260 次浏览 来自 问答

在进行node-gyp configure build 出现这样错误: node-gyp/5.2.0/include/node/node.h:419:43: error: overloaded function with no contextual type information (node::addon_register_func) (regfunc),
在其他的Ubuntu环境下没问题

1 回复

你自己写的c艹模块还是第三方的,估计是nan版本不兼容。从0.10到5经历了0.12,4几个v8大版本升级,nan的写法也升级了好几次,如果模块没更新的话编译通不过的。 From Noder

回到顶部