npm install -g n 出问题了,帮忙看看。
发布于 8 年前 作者 profangong 10520 次浏览 来自 问答

我想升级nodejs,看网上说可以用n模块升级,就用想用n来升级,不料出了这样的问题。 1.png 我的系统是32位的win7,截图中的 ‘valid os: !win32’ 意思是要求不是32位的吗? 另外,我直接手动新安装nodejs到现有目录,可以不。还没动手,怕引出别的问题。苦恼啊。

10 回复

自己看官方文档,都说了不支持win了,nvm也不支持win

@i5ting 晕又是个坑啊,那我直接手动安装nodejs到现有目录,是没问题的吧。

@i5ting win 64 nvm 应该没问题

https://github.com/tj/n n 是 bash 写的,windows 又不支持

windows上想用啥版本,只能到官网上去下载可安装文件了

不支持windows

多谢各位恢复,弱问一句,github上面很多时候下载下来都是源文件,不是可执行文件,不会每次都自己编译吧,请问什么地方是下可执行文件呢。比如: 2.png

哈哈, win32升级,还是去官网下载安装吧,也花不了2分钟

@profangong 一般在release里有exe文件

回到顶部