怎么解决mongoose的过期 library问题
发布于 3 年前 作者 cnlile 9190 次浏览 来自 问答

安装一个新的服务,也没注意,直接npm install mongoose , 结果运行服务出错: Mongoose: mpromise (mongoose’s default promise library) is deprecated, plug in your own promise library instead: http://mongoosejs.com/docs/promises.html 不知道什么问题,mongoose 更新了什么。。。?如何解决?

3 回复
http://stackoverflow.com/questions/38138445/node3341-deprecationwarning-mongoose-mpromise
https://github.com/Automattic/mongoose/wiki/5.0-Deprecation-Warnings

把 mongoose.Promise = global.Promise; 加在 mongoose.connect(MONGO_URI); 之前

已经这样做了

回到顶部