Android和IOS连接socket.io的方案
发布于 6 年前 作者 shizhangfan 4614 次浏览 来自 问答

我在做一个聊天的程序,之前使用的是node的net模块。可是不知道是不是我的移动端代码有问题,socket老是会变成不可写(我通过writable来判断,总是会变成false)。现在想用socket.io来做,android的可以用1.0以上版本的socket.io 但是IOS只能用0.9版本的,我用O-C写的。请问有什么解决方案吗?因为如果服务器用0.9版本的话,android会连不上,如果用1.0以上版本的,IOS又连不上。弄了好几天了,没有结果。希望有经验的前辈指点一二。

3 回复

监听 disconnected 之后去重新连接。

已经解决了 在github上翻到两个很旧的库 都支持0.9版本的socket.io

回到顶部