小白请问下这种报错是这么回事?
发布于 3 年前 作者 xxc0916 2185 次浏览 来自 问答

请问下在学习《一起学 Node.js》的时候,到了注册这一步,mongoless模块的 query.js 报错, #报错信息如下: g:\myblog\node_modules\mongolass\lib\query.js:53 this[plugin.name] = (…args) => { ^^^

SyntaxError: Unexpected token … at exports.runInThisContext (vm.js:53:16) at Module._compile (module.js:374:25) at Object.Module._extensions…js (module.js:417:10) at Module.load (module.js:344:32) at Function.Module._load (module.js:301:12) at Module.require (module.js:354:17) at require (internal/module.js:12:17) at Object.<anonymous> (g:\myblog\node_modules\mongolass\lib\model.js:7:15) at Module._compile (module.js:410:26) at Object.Module._extensions…js (module.js:417:10) at Module.load (module.js:344:32) at Function.Module._load (module.js:301:12) at Module.require (module.js:354:17) at require (internal/module.js:12:17) at Object.<anonymous> (g:\myblog\node_modules\mongolass\lib\index.js:7:15) at Module._compile (module.js:410:26) 一开始编辑器不支持ES6语法,后来调整了设置,就报这种错。

10 回复

语法错误!

@duzitengg 请问下是哪里的语法错误,我mongoless模块是直接下载的呀,我没有动过他的代码。

看你53行的代码啊!我这也看不到你的代码!

是什么东西报的错?编辑器报的吗?还是 build 脚本报的?

@xcatliu 编辑器报的错。

那就是编辑器不支持这种语法吧

@xcatliu untitled1.png已经设置支持ES6了,看语法应该是es6的呀。

@xcatliu 谢谢你我知道了,原来是我node版本太低4.2.6,不支持这种语法,升级后好了。不过我记得4.0版本后就支持ES6了呀

回到顶部