electron 安装报错
发布于 4 年前 作者 biuge 10132 次浏览 来自 问答

Node版本7.8.0 npm 4.2.0 安装electron 1.6.6版本报错

> electron@1.6.6 postinstall /Users/xx/node_modules/electron
> node install.js
/Users/chenlei/node_modules/electron/install.js:47
  throw err
  ^

Error: connect ETIMEDOUT 54.231.34.41:443
    at Object.exports._errnoException (util.js:1034:11)
    at exports._exceptionWithHostPort (util.js:1057:20)
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1096:14)
npm WARN vue-loader@8.7.0 requires a peer of babel-runtime@^6.0.0 but none was installed.
npm WARN chenlei@1.0.0 No description
npm WARN chenlei@1.0.0 No repository field.
npm ERR! Darwin 15.4.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "electron" "--save-dev"
npm ERR! node v7.8.0
npm ERR! npm  v4.2.0
npm ERR! code ELIFECYCLE
npm ERR! errno 1

github上找到关于报错的原因 https://github.com/electron/electron/issues/9323 是extract-zip的bug 具体的解决方案我看好像是改成1.6.5就可以 但是我现在遇到的问题是 全局安装报错 然后项目就没有了 没法改package.json 然后.npm 缓存里的信息我改了 npm貌似不从缓存里拿信息 还是没用 已经被这个问题卡了两天了 求大家帮助

7 回复

ETIMEDOUT…是在拉electron五十几M的源码啊, 你用cnpm安就好了

@Smallpath 我使用cnpm安装也是这个问题

那你可以直接去淘宝镜像下二进制文件,自己解压

ELECTRON_MIRROR=http://npm.taobao.org/mirrors/electron/ npm install -g electron 你需要的是这个

或者直接添加变量 export ELECTRON_MIRROR=http://npm.taobao.org/mirrors/electron/ 到 .bashrc、.zshrc、.bash_profile、.profile等等,然后正常安装就行

win下请忽略,直接下载二进制文件,然后解压目标添加到环境变量

其实翻墙就可以了…你查到的错误应该和你这个报错没有关系…错误显示是:连接超时…

回到顶部