npm与cnpm安装模块版本问题
发布于 1 个月前 作者 silenceboychen 286 次浏览 来自 问答

node版本一样,本地使用npm安装模块,并在发布前使用npm shrinkwrap锁定版本。线上使用的是cnpm,安装模块时,会出现有些模块的版本号不一样。cnpm是不是不会读npm-shrinkwrap.json文件,还是其他的原因,有人知道吗?

5 回复

package.json里对应模块版本是写死了的么?

@imhered 用了npm shrinkwrap锁定了

@silenceboychen 找找官方人员吧,也在社区里。 我一直都是用的npm没用过cnpm😂

回到顶部