require引用自定义模块报错
发布于 3 年前 作者 bigsomg 3047 次浏览 来自 问答

问题描述:引用自定义模块报错, 模块定义如下: image.png 引用方式如下: image.png

环境:Win7 64bit npm版本,以及node版本报错信息如下: image.png

还请大神帮忙指出一下哪里错了,这里十分感谢!

11 回复

PAIkey的 冒号

@unliar 冒汗都是英文的,key那里少了个空格,应该不是这个问题吧。而且符号不对的报错信息也不是这样呀 From Noder

@htoooth 重写过了还是没用呀 image.png

这是语法问题,开个webstorm看一下它的报错提示吧。 括号没对上什么的。

只知道报错的那句是源码,,

建议重新下个node

我觉得你应该把config致空对象,看看是不是报错!感觉就是中英文问题 From Noder

@dukegod 置空没用,我把config.js全部重写还是这样。。

@all 感谢各位大佬看这里,我已经找到原因了,。。 归结起来就是坑人的Windows,自己一直用Ubuntu,这两天在公司比较闲就准备搞个小东西玩,结果就被坑了一波。我也不知道为什么编码变成了UTF-16???。。重新改了一下编码就好了,再次感谢各位!

看到乱码,感觉是编码问题。

编码问题吧

回到顶部