如何检测node_module内的包版本和yarn配置文件中的匹配度
发布于 1 年前 作者 backlost 1549 次浏览 来自 问答

现在的build脚本每次都会rm -rf nodemodule 再yarn 感觉太浪费时间了,尤其node-sass编译好久 想稍微优化一下,有没有什么比较好的工具帮忙check yarn version,如果nodeModule里面的版本都对,就不clean了

2 回复

不用, 直接以lock文件为准

@captainblue2013 不是,主要是每次安装太慢了,但是安装脚本如果不写为 rm -rf node_module && yarn 又觉得不安全。 所以想搞个脚本/工具如果检测到node_module里面的内容和lock文件一致就不删除安装了

回到顶部