求助关于RN的问题,Print: Entry, ":CFBundleIdentifier", Does Not Exist
发布于 9 个月前 作者 imzengyang 2890 次浏览 来自 问答

这个问题网上搜遍了,依旧没有找到解决办法,非常困恼,现在向论坛求助; 现在说明下我的环境 nodejs:8.10.0 mac:10.13.3 (17D102) react-native-cli: 2.0.1 react-native: 0.54.2 npm:5.6.0 yarn:1.5.1

问题: 使用react-native init Uber 创建好项目,进入项目cd Uber 运行 react-native run-ios, 报错:

Command failed: /usr/libexec/PlistBuddy -c Print:CFBundleIdentifier build/Build/Products/Debug-iphonesimulator/Uber.app/Info.plist
Print: Entry, ":CFBundleIdentifier", Does Not Exist

看了很多贴子,说新版本RN 需要安装对应Boost等文件。 ~/.rncache 目录下也把这几个文件下载了。 image.png 但是依旧还是报这个错误。

8 回复

感觉报错信息不全,没贴重点

谢谢,这是具体的报错

** BUILD FAILED **


The following build commands failed:
	CompileC /Users/zack-zhao/myapp/Uber/ios/build/Build/Intermediates/React.build/Debug-iphonesimulator/React.build/Objects-normal/x86_64/RCTMessageThread.o CxxBridge/RCTMessageThread.mm normal x86_64 objective-c++ com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)

Installing build/Build/Products/Debug-iphonesimulator/Uber.app
An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):
Failed to install the requested application
An application bundle was not found at the provided path.
Provide a valid path to the desired application bundle.
Print: Entry, ":CFBundleIdentifier", Does Not Exist

Command failed: /usr/libexec/PlistBuddy -c Print:CFBundleIdentifier build/Build/Products/Debug-iphonesimulator/Uber.app/Info.plist
Print: Entry, ":CFBundleIdentifier", Does Not Exist

再往回翻翻,估计还有更具体的报错

别折腾了. 如果是初学的话,直接使用expo 入门吧! 直接略过配置部分. 如果是产品级的参考下面 https://github.com/facebook/react-native/issues/14423

en, 不折腾了,react-native init myapp --version 0.44.3

以前碰到过,应该是要升级xcode 来自react native cnode

@Dirmond 谢谢,晚上我再试试。

@Dirmond 都升级了一把 最新版的xcode,问题已经不存在,谢谢

回到顶部