请教各位 nodejs 如何安装web3.js的某个特定版本
发布于 10 天前 作者 jiangzijian 427 次浏览 来自 问答

个人在安装web3.js的时候报错了,然后在网上找到解决办法了之后,只是知其然不知其所以然,安装了之后发现部分api没有办法调用 查到可能是版本的原因。 所以在这请教知道的大佬,如何安装指定版本。 当前的安装语句 :npm install web3@^0.20.0 我想安装1.4这种版本。

2 回复

只要对应版本在npm能找到,直接替换版本号不就好了么… npm install moduleName@version

问题已经解决了,这个问题的来龙去脉是:第一次安装web3的时候报错了,在网上查找了之后,有个办法就是使用指定版本就可以安装了。在安装成功了之后发现,部分的api是不能调用的,在stackoverflow 上面有人说是版本的原因,我看了我同事的web3的版本之后,发现他用的是最新版的,然后发现我第一次解决问题的思路是不太对的,没有解决当时的问题,而是通过选择版本号绕过了这个问题。后来解决了两个问题后就可以正确的安装最新的版本了。api的问题也没有了。

回到顶部