react项目,升级node版本后,运行yarn start报错
发布于 9 个月前 作者 imizao 1395 次浏览 来自 问答

image.png node版本: 升级前:v11.2.~ 升级后:v12.0.0 也将npm升级到最新版本。 目前运行项目就报这个问题。 试过重新 create-react-app ,运行时也同样报错,如图** image.png 遇到这种问题,怎么处理?

补充内容: Error: fsevents is not a constructor这个我百度了,解决方案是卸载再升级truffle,试了,结果跟第二个图一样。**

4 回复

fsevents 是 C++ 插件,还不支持 12,你安装依赖的时候没看报错信息么?

@atian25 将node版本回退了,解决了,蟹蟹大佬

Node 11 也不要用,单数都不是稳定版本。可以去了解下 Node LTS 的概念,坚持只用最新的 LTS。https://github.com/nodejs/Release

@atian25 只用 lts 版本。 目前是node10 前端追求高版本的 node 也增加不了性能额~~

回到顶部