NPM安装NODEJS类程序。跳需求react@^15.0.0. 安装后 跳需求react@^16.2.0,再安装再跳回需求react@^15.0.0
发布于 5 个月前 作者 pibc-cts 805 次浏览 来自 问答

NPM安装NODEJS类程序。跳需求react@^15.0.0. 安装后npm install react@^15.0.0 跳需求react@^16.2.0,再安装react@^16.2.0 再跳回需求react@^15.0.0. 总结就是 装了15 报错要 16 再装了16 报错 要15. 根本原因 大概会是什么啊, 小白安装, 不懂NODEJS。 https://img.vim-cn.com/43/260f05defa2c748ea1b803902cf8b62357ba28.jpg https://img.vim-cn.com/f7/4a5bc364ebf487a202e7c3cc1304a939cbd391.jpg

4 回复

antd 版本换个低点吧! 还有点建议,如果是中后台系统,建议angular4+,react一时爽,一直重构一直爽,别成码农了哈,低成本迭代和服务客户才是关键

一般默认装latest,能跑起来就不用管

跑不起来啊, 然后 直接 NPM start 失败 有一些JS 没有。

react-sticky-table@1.2.0 需要 react 15 antd@3.18.2 需要 react 16

可以看一下 react-sticky-table 是否有技术 react 16的版本,有的话,安装指定版本就可以了。 或把 antd的版本降到 可以使用 react 15 版本的就可以了。

回到顶部