弱弱问一句,node12还是不支持运行js的装饰器嘛?
发布于 2 个月前 作者 Rabbitzzc 993 次浏览 来自 问答

想知道用node 运行带有装饰器的js文件为啥会报错 谢谢啦

5 回复

装饰器在 ecma 标准里还只是一个 stage2 的 提案,还没有正式稳定下来,Node 还不会支持。可以使用 Babel 或者 Typescript

decorators 都好多年了,还在 stage2,而且中间已经有不少于两次的比较大的 break change

还是直接 typescript比较合适

@rrbe难怪,ts倒是支持,谢谢你啦

@justjavac 不清楚为啥,这功能挺好用的

回到顶部