关于mac os catalina 下node_modules安装报错以及处理
发布于 20 天前 作者 WillWuWeijie 511 次浏览 来自 分享

gyp: No Xcode or CLT version detected! gyp ERR! configure error gyp ERR! stack Error: gyp failed with exit code: 1 gyp ERR! stack at ChildProcess.onCpExit (/usr/local/lib/node_modules/cnpm/node_modules/node-gyp/lib/configure.js:345:16) gyp ERR! stack at ChildProcess.emit (events.js:210:5) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12) gyp ERR! System Darwin 19.0.0 gyp ERR! command “/usr/local/Cellar/node@12/12.13.1/bin/node” “/usr/local/lib/node_modules/cnpm/node_modules/npminstall/node-gyp-bin/node-gyp.js” "rebuild" gyp ERR! cwd /Users/will/git.keyiu.com/fencing-merchant/node_modules/_node-pty@0.10.0-beta3@node-pty gyp ERR! node -v v12.13.1 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok 网上目前能找到的处理方式一般就是sudo xcode-select --install 如果你试过这些方式,还是解决不了的话不妨打开xcode看看这个东西是不是丢了WX20191120-174945.png

回到顶部