npm update出现的WARN
发布于 7 年前 作者 tolerious 23498 次浏览 最后一次编辑是 5 年前 来自 问答

Snip20140907_1.png

这第一句话,npm WARN unmet dependency /usr/local/lib/node_modules/cnpm/node_modules/urllib requires debug@'0.8.1' but will load的意思, 是不是意思说我的debug这个包的版本太低了,要装个0.8.1版本的?

已经安装的moudle有:


/usr/local/lib
├─┬ bl[@0](/user/0).9.1
│ └─┬ readable-stream[@1](/user/1).0.31
│   ├── core-util-is[@1](/user/1).0.1
│   ├── inherits[@2](/user/2).0.1
│   ├── isarray[@0](/user/0).0.1
│   └── string_decoder[@0](/user/0).10.31
├─┬ cnpm[@1](/user/1).0.0
│ ├── auto-correct[@1](/user/1).0.0
│ ├── bagpipe[@0](/user/0).3.5
│ ├── colors[@0](/user/0).6.2
│ ├── commander[@2](/user/2).3.0
│ ├── cross-spawn[@0](/user/0).1.7
│ ├─┬ debug[@1](/user/1).0.4
│ │ └── ms[@0](/user/0).6.2
│ ├── giturl[@0](/user/0).0.3
│ ├─┬ npm[@2](/user/2).0.0-beta.3
│ │ ├── abbrev[@1](/user/1).0.5
│ │ ├── ansi[@0](/user/0).3.0
│ │ ├── ansicolors[@0](/user/0).3.2
│ │ ├── ansistyles[@0](/user/0).1.3
│ │ ├── archy[@0](/user/0).0.2
│ │ ├── async-some[@1](/user/1).0.1
│ │ ├── block-stream[@0](/user/0).0.7
│ │ ├── char-spinner[@1](/user/1).0.1
│ │ ├── child-process-close[@0](/user/0).1.1
│ │ ├── chmodr[@0](/user/0).1.0
│ │ ├── chownr[@0](/user/0).0.1
│ │ ├── cmd-shim[@2](/user/2).0.0 (git://github.com/othiym23/cmd-shim#12de64ca97f45ac600910092f19afacc3d5376dd)
│ │ ├─┬ columnify[@1](/user/1).2.1
│ │ │ ├─┬ strip-ansi[@1](/user/1).0.0
│ │ │ │ └── ansi-regex[@0](/user/0).2.1
│ │ │ └─┬ wcwidth[@1](/user/1).0.0
│ │ │   └─┬ defaults[@1](/user/1).0.0
│ │ │     └── clone[@0](/user/0).1.18
│ │ ├─┬ dezalgo[@1](/user/1).0.0
│ │ │ └── asap[@1](/user/1).0.0
│ │ ├── editor[@0](/user/0).1.0
│ │ ├── fs-vacuum[@1](/user/1).2.1
│ │ ├── fstream[@1](/user/1).0.2
│ │ ├─┬ fstream-npm[@1](/user/1).0.0
│ │ │ └── fstream-ignore[@1](/user/1).0.1
│ │ ├── github-url-from-git[@1](/user/1).4.0
│ │ ├── github-url-from-username-repo[@1](/user/1).0.2
│ │ ├── glob[@4](/user/4).0.5
│ │ ├── graceful-fs[@3](/user/3).0.2
│ │ ├── inflight[@1](/user/1).0.1
│ │ ├── inherits[@2](/user/2).0.1
│ │ ├── ini[@1](/user/1).2.1
│ │ ├─┬ init-package-json[@1](/user/1).0.0
│ │ │ └── promzard[@0](/user/0).2.2
│ │ ├── lockfile[@1](/user/1).0.0
│ │ ├── lru-cache[@2](/user/2).5.0
│ │ ├─┬ minimatch[@1](/user/1).0.0
│ │ │ └── sigmund[@1](/user/1).0.0
│ │ ├─┬ mkdirp[@0](/user/0).5.0
│ │ │ └── minimist[@0](/user/0).0.8
│ │ ├── node-gyp[@1](/user/1).0.1
│ │ ├── nopt[@3](/user/3).0.1
│ │ ├── normalize-package-data[@1](/user/1).0.1
│ │ ├── npm-cache-filename[@1](/user/1).0.1
│ │ ├── npm-install-checks[@1](/user/1).0.3
│ │ ├── npm-package-arg[@2](/user/2).1.0
│ │ ├── npm-registry-client[@3](/user/3).1.7
│ │ ├── npm-user-validate[@0](/user/0).1.0
│ │ ├─┬ npmconf[@2](/user/2).0.8
│ │ │ └─┬ config-chain[@1](/user/1).1.8
│ │ │   └── proto-list[@1](/user/1).2.3
│ │ ├── npmlog[@0](/user/0).1.1
│ │ ├── once[@1](/user/1).3.0
│ │ ├── opener[@1](/user/1).3.0
│ │ ├── osenv[@0](/user/0).1.0
│ │ ├── path-is-inside[@1](/user/1).0.1
│ │ ├─┬ read[@1](/user/1).0.5
│ │ │ └── mute-stream[@0](/user/0).0.4
│ │ ├─┬ read-installed[@3](/user/3).1.1
│ │ │ ├── debuglog[@1](/user/1).0.1
│ │ │ ├── readdir-scoped-modules[@1](/user/1).0.0
│ │ │ └── util-extend[@1](/user/1).0.1
│ │ ├── read-package-json[@1](/user/1).2.7
│ │ ├─┬ request[@2](/user/2).42.0
│ │ │ ├── aws-sign2[@0](/user/0).5.0
│ │ │ ├─┬ bl[@0](/user/0).9.1
│ │ │ │ └─┬ readable-stream[@1](/user/1).0.31
│ │ │ │   ├── core-util-is[@1](/user/1).0.1
│ │ │ │   ├── isarray[@0](/user/0).0.1
│ │ │ │   └── string_decoder[@0](/user/0).10.31
│ │ │ ├── caseless[@0](/user/0).6.0
│ │ │ ├── forever-agent[@0](/user/0).5.2
│ │ │ ├─┬ form-data[@0](/user/0).1.4
│ │ │ │ ├── async[@0](/user/0).9.0
│ │ │ │ ├─┬ combined-stream[@0](/user/0).0.5
│ │ │ │ │ └── delayed-stream[@0](/user/0).0.5
│ │ │ │ └── mime[@1](/user/1).2.11
│ │ │ ├─┬ hawk[@1](/user/1).1.1
│ │ │ │ ├── boom[@0](/user/0).4.2
│ │ │ │ ├── cryptiles[@0](/user/0).2.2
│ │ │ │ ├── hoek[@0](/user/0).9.1
│ │ │ │ └── sntp[@0](/user/0).2.4
│ │ │ ├─┬ http-signature[@0](/user/0).10.0
│ │ │ │ ├── asn1[@0](/user/0).1.11
│ │ │ │ ├── assert-plus[@0](/user/0).1.2
│ │ │ │ └── ctype[@0](/user/0).5.2
│ │ │ ├── json-stringify-safe[@5](/user/5).0.0
│ │ │ ├── mime-types[@1](/user/1).0.2
│ │ │ ├── node-uuid[@1](/user/1).4.1
│ │ │ ├── oauth-sign[@0](/user/0).4.0
│ │ │ ├── qs[@1](/user/1).2.2
│ │ │ ├── stringstream[@0](/user/0).0.4
│ │ │ ├─┬ tough-cookie[@0](/user/0).12.1
│ │ │ │ └── punycode[@1](/user/1).3.1
│ │ │ └── tunnel-agent[@0](/user/0).4.0
│ │ ├── retry[@0](/user/0).6.0
│ │ ├── rimraf[@2](/user/2).2.8
│ │ ├── semver[@3](/user/3).0.1
│ │ ├─┬ sha[@1](/user/1).2.4
│ │ │ └─┬ readable-stream[@1](/user/1).0.27-1
│ │ │   ├── core-util-is[@1](/user/1).0.1
│ │ │   ├── isarray[@0](/user/0).0.1
│ │ │   └── string_decoder[@0](/user/0).10.25-1
│ │ ├── slide[@1](/user/1).1.5
│ │ ├── sorted-object[@1](/user/1).0.0
│ │ ├── tar[@1](/user/1).0.1
│ │ ├── text-table[@0](/user/0).2.0
│ │ ├── uid-number[@0](/user/0).0.5
│ │ └── which[@1](/user/1).0.5
│ ├─┬ npm-request[@0](/user/0).0.4
│ │ └─┬ urllib[@0](/user/0).5.11
│ │   ├── debug[@0](/user/0).7.4
│ │   └── default-user-agent[@0](/user/0).0.1
│ ├── open[@0](/user/0).0.5
│ └─┬ urllib[@0](/user/0).5.17
│   ├── debug[@0](/user/0).8.1
│   ├── default-user-agent[@0](/user/0).0.1
│   └─┬ digest-header[@0](/user/0).0.1
│     └─┬ utility[@0](/user/0).1.11
│       └── address[@0](/user/0).0.3
├─┬ express[@4](/user/4).8.8
│ ├─┬ accepts[@1](/user/1).0.7
│ │ ├── mime-types[@1](/user/1).0.2
│ │ └── negotiator[@0](/user/0).4.7
│ ├── buffer-crc32[@0](/user/0).2.3
│ ├── cookie[@0](/user/0).1.2
│ ├── cookie-signature[@1](/user/1).0.4
│ ├─┬ debug[@1](/user/1).0.4
│ │ └── ms[@0](/user/0).6.2
│ ├── depd[@0](/user/0).4.4
│ ├── escape-html[@1](/user/1).0.1
│ ├── finalhandler[@0](/user/0).1.0
│ ├── fresh[@0](/user/0).2.2
│ ├── media-typer[@0](/user/0).2.0
│ ├── merge-descriptors[@0](/user/0).0.2
│ ├── methods[@1](/user/1).1.0
│ ├── parseurl[@1](/user/1).3.0
│ ├── path-to-regexp[@0](/user/0).1.3
│ ├─┬ proxy-addr[@1](/user/1).0.1
│ │ └── ipaddr.js[@0](/user/0).1.2
│ ├── qs[@2](/user/2).2.2
│ ├── range-parser[@1](/user/1).0.0
│ ├─┬ send[@0](/user/0).8.5
│ │ ├── debug[@1](/user/1).0.4
│ │ ├── destroy[@1](/user/1).0.3
│ │ ├── mime[@1](/user/1).2.11
│ │ ├── ms[@0](/user/0).6.2
│ │ └─┬ on-finished[@2](/user/2).1.0
│ │   └── ee-first[@1](/user/1).0.5
│ ├── serve-static[@1](/user/1).5.4
│ ├─┬ type-is[@1](/user/1).3.2
│ │ └── mime-types[@1](/user/1).0.2
│ ├── utils-merge[@1](/user/1).0.0
│ └── vary[@0](/user/0).1.0
├─┬ express-generator[@4](/user/4).8.0
│ ├─┬ commander[@1](/user/1).3.2
│ │ └── keypress[@0](/user/0).1.0
│ └─┬ mkdirp[@0](/user/0).5.0
│   └── minimist[@0](/user/0).0.8
├─┬ learnyounode[@1](/user/1).0.1
│ ├── after[@0](/user/0).8.1
│ ├─┬ bl[@0](/user/0).7.0
│ │ └─┬ readable-stream[@1](/user/1).0.31
│ │   ├── core-util-is[@1](/user/1).0.1
│ │   ├── inherits[@2](/user/2).0.1
│ │   ├── isarray[@0](/user/0).0.1
│ │   └── string_decoder[@0](/user/0).10.31
│ ├── boganipsum[@0](/user/0).1.0
│ ├─┬ chalk[@0](/user/0).4.0
│ │ ├── ansi-styles[@1](/user/1).0.0
│ │ ├── has-color[@0](/user/0).1.7
│ │ └── strip-ansi[@0](/user/0).1.1
│ ├─┬ colors-tmpl[@0](/user/0).1.0
│ │ └── colors[@0](/user/0).6.2
│ ├─┬ concat-stream[@1](/user/1).4.6
│ │ ├── inherits[@2](/user/2).0.1
│ │ ├─┬ readable-stream[@1](/user/1).1.13
│ │ │ ├── core-util-is[@1](/user/1).0.1
│ │ │ ├── isarray[@0](/user/0).0.1
│ │ │ └── string_decoder[@0](/user/0).10.31
│ │ └── typedarray[@0](/user/0).0.6
│ ├── duplexer[@0](/user/0).1.1
│ ├─┬ hyperquest[@0](/user/0).2.0
│ │ └── through[@2](/user/2).2.7
│ ├── rimraf[@2](/user/2).2.8
│ ├─┬ stream-browserify[@1](/user/1).0.0
│ │ ├── inherits[@2](/user/2).0.1
│ │ └─┬ readable-stream[@1](/user/1).0.27-1
│ │   ├── core-util-is[@1](/user/1).0.1
│ │   ├── isarray[@0](/user/0).0.1
│ │   └── string_decoder[@0](/user/0).10.25-1
│ ├── through[@2](/user/2).3.4
│ ├─┬ through2[@0](/user/0).4.2
│ │ ├─┬ readable-stream[@1](/user/1).0.31
│ │ │ ├── core-util-is[@1](/user/1).0.1
│ │ │ ├── inherits[@2](/user/2).0.1
│ │ │ ├── isarray[@0](/user/0).0.1
│ │ │ └── string_decoder[@0](/user/0).10.31
│ │ └─┬ xtend[@2](/user/2).1.2
│ │   └── object-keys[@0](/user/0).4.0
│ ├─┬ through2-map[@1](/user/1).4.0
│ │ ├─┬ terminus[@1](/user/1).0.10
│ │ │ ├─┬ readable-stream[@1](/user/1).0.31
│ │ │ │ ├── core-util-is[@1](/user/1).0.1
│ │ │ │ ├── inherits[@2](/user/2).0.1
│ │ │ │ ├── isarray[@0](/user/0).0.1
│ │ │ │ └── string_decoder[@0](/user/0).10.31
│ │ │ └── xtend[@3](/user/3).0.0
│ │ ├─┬ through2[@0](/user/0).5.1
│ │ │ └─┬ readable-stream[@1](/user/1).0.31
│ │ │   ├── core-util-is[@1](/user/1).0.1
│ │ │   ├── inherits[@2](/user/2).0.1
│ │ │   ├── isarray[@0](/user/0).0.1
│ │ │   └── string_decoder[@0](/user/0).10.31
│ │ └── xtend[@3](/user/3).0.0
│ ├─┬ workshopper[@1](/user/1).3.2
│ │ ├─┬ chalk[@0](/user/0).4.0
│ │ │ ├── ansi-styles[@1](/user/1).0.0
│ │ │ ├── has-color[@0](/user/0).1.7
│ │ │ └── strip-ansi[@0](/user/0).1.1
│ │ ├── map-async[@0](/user/0).1.1
│ │ ├── mkdirp[@0](/user/0).3.5
│ │ ├─┬ msee[@0](/user/0).1.1
│ │ │ ├─┬ cardinal[@0](/user/0).4.4
│ │ │ │ ├── ansicolors[@0](/user/0).2.1
│ │ │ │ └─┬ redeyed[@0](/user/0).4.4
│ │ │ │   └── esprima[@1](/user/1).0.4
│ │ │ ├─┬ chalk[@0](/user/0).4.0
│ │ │ │ ├── ansi-styles[@1](/user/1).0.0
│ │ │ │ ├── has-color[@0](/user/0).1.7
│ │ │ │ └── strip-ansi[@0](/user/0).1.1
│ │ │ ├── marked[@0](/user/0).3.2
│ │ │ ├─┬ nopt[@2](/user/2).1.2
│ │ │ │ └── abbrev[@1](/user/1).0.5
│ │ │ └─┬ xtend[@2](/user/2).1.2
│ │ │   └── object-keys[@0](/user/0).4.0
│ │ ├─┬ optimist[@0](/user/0).6.1
│ │ │ ├── minimist[@0](/user/0).0.10
│ │ │ └── wordwrap[@0](/user/0).0.2
│ │ ├─┬ terminal-menu[@0](/user/0).3.2
│ │ │ ├── charm[@0](/user/0).1.2
│ │ │ ├── inherits[@2](/user/2).0.1
│ │ │ └── resumer[@0](/user/0).0.0
│ │ └── xtend[@3](/user/3).0.0
│ ├── workshopper-boilerplate[@0](/user/0).0.1
│ ├─┬ workshopper-exercise[@0](/user/0).2.3
│ │ ├── split[@0](/user/0).3.0
│ │ ├── tuple-stream[@0](/user/0).0.2
│ │ └─┬ xtend[@2](/user/2).1.2
│ │   └── object-keys[@0](/user/0).4.0
│ └─┬ workshopper-wrappedexec[@0](/user/0).1.1
│   └─┬ xtend[@2](/user/2).1.2
│     └── object-keys[@0](/user/0).4.0
├─┬ npm[@1](/user/1).4.26
│ ├── abbrev[@1](/user/1).0.5
│ ├── ansi[@0](/user/0).3.0
│ ├── ansicolors[@0](/user/0).3.2
│ ├── ansistyles[@0](/user/0).1.3
│ ├── archy[@0](/user/0).0.2
│ ├── block-stream[@0](/user/0).0.7
│ ├── char-spinner[@1](/user/1).0.1
│ ├── child-process-close[@0](/user/0).1.1
│ ├── chmodr[@0](/user/0).1.0
│ ├── chownr[@0](/user/0).0.1
│ ├─┬ cmd-shim[@2](/user/2).0.0
│ │ └── graceful-fs[@2](/user/2).0.3
│ ├─┬ columnify[@1](/user/1).2.1
│ │ ├─┬ strip-ansi[@1](/user/1).0.0
│ │ │ └── ansi-regex[@0](/user/0).2.1
│ │ └─┬ wcwidth[@1](/user/1).0.0
│ │   └─┬ defaults[@1](/user/1).0.0
│ │     └── clone[@0](/user/0).1.18
│ ├── editor[@0](/user/0).1.0
│ ├── fstream[@1](/user/1).0.2
│ ├─┬ fstream-npm[@1](/user/1).0.0
│ │ └── fstream-ignore[@1](/user/1).0.1
│ ├── github-url-from-git[@1](/user/1).4.0
│ ├── github-url-from-username-repo[@1](/user/1).0.2
│ ├── glob[@4](/user/4).0.5
│ ├── graceful-fs[@3](/user/3).0.2
│ ├── inflight[@1](/user/1).0.1
│ ├── inherits[@2](/user/2).0.1
│ ├── ini[@1](/user/1).2.1
│ ├─┬ init-package-json[@1](/user/1).0.0
│ │ ├── promzard[@0](/user/0).2.2
│ │ └── semver[@3](/user/3).0.1
│ ├── lockfile[@1](/user/1).0.0
│ ├── lru-cache[@2](/user/2).5.0
│ ├─┬ minimatch[@1](/user/1).0.0
│ │ └── sigmund[@1](/user/1).0.0
│ ├─┬ mkdirp[@0](/user/0).5.0
│ │ └── minimist[@0](/user/0).0.8
│ ├─┬ node-gyp[@1](/user/1).0.1
│ │ ├─┬ request[@2](/user/2).42.0
│ │ │ ├── aws-sign2[@0](/user/0).5.0
│ │ │ ├─┬ bl[@0](/user/0).9.1
│ │ │ │ └─┬ readable-stream[@1](/user/1).0.31
│ │ │ │   ├── core-util-is[@1](/user/1).0.1
│ │ │ │   ├── inherits[@2](/user/2).0.1
│ │ │ │   ├── isarray[@0](/user/0).0.1
│ │ │ │   └── string_decoder[@0](/user/0).10.31
│ │ │ ├── caseless[@0](/user/0).6.0
│ │ │ ├── forever-agent[@0](/user/0).5.2
│ │ │ ├─┬ form-data[@0](/user/0).1.4
│ │ │ │ ├── async[@0](/user/0).9.0
│ │ │ │ ├─┬ combined-stream[@0](/user/0).0.5
│ │ │ │ │ └── delayed-stream[@0](/user/0).0.5
│ │ │ │ └── mime[@1](/user/1).2.11
│ │ │ ├─┬ hawk[@1](/user/1).1.1
│ │ │ │ ├── boom[@0](/user/0).4.2
│ │ │ │ ├── cryptiles[@0](/user/0).2.2
│ │ │ │ ├── hoek[@0](/user/0).9.1
│ │ │ │ └── sntp[@0](/user/0).2.4
│ │ │ ├─┬ http-signature[@0](/user/0).10.0
│ │ │ │ ├── asn1[@0](/user/0).1.11
│ │ │ │ ├── assert-plus[@0](/user/0).1.2
│ │ │ │ └── ctype[@0](/user/0).5.2
│ │ │ ├── json-stringify-safe[@5](/user/5).0.0
│ │ │ ├── mime-types[@1](/user/1).0.2
│ │ │ ├── node-uuid[@1](/user/1).4.1
│ │ │ ├── oauth-sign[@0](/user/0).4.0
│ │ │ ├── qs[@1](/user/1).2.2
│ │ │ ├── stringstream[@0](/user/0).0.4
│ │ │ ├─┬ tough-cookie[@0](/user/0).12.1
│ │ │ │ └── punycode[@1](/user/1).3.1
│ │ │ └── tunnel-agent[@0](/user/0).4.0
│ │ └── semver[@3](/user/3).0.1
│ ├── nopt[@3](/user/3).0.1
│ ├── npm-cache-filename[@1](/user/1).0.1
│ ├─┬ npm-install-checks[@1](/user/1).0.3
│ │ └── semver[@3](/user/3).0.1
│ ├─┬ npm-registry-client[@2](/user/2).0.7
│ │ └── retry[@0](/user/0).6.0
│ ├── npm-user-validate[@0](/user/0).1.0
│ ├─┬ npmconf[@1](/user/1).1.8
│ │ ├─┬ config-chain[@1](/user/1).1.8
│ │ │ └── proto-list[@1](/user/1).2.3
│ │ └── semver[@2](/user/2).3.2
│ ├── npmlog[@0](/user/0).1.1
│ ├── once[@1](/user/1).3.0
│ ├── opener[@1](/user/1).3.0
│ ├── osenv[@0](/user/0).1.0
│ ├── path-is-inside[@1](/user/1).0.1
│ ├─┬ read[@1](/user/1).0.5
│ │ └── mute-stream[@0](/user/0).0.4
│ ├─┬ read-installed[@2](/user/2).0.7
│ │ └── util-extend[@1](/user/1).0.1
│ ├─┬ read-package-json[@1](/user/1).2.7
│ │ ├── github-url-from-username-repo[@1](/user/1).0.2
│ │ └─┬ normalize-package-data[@1](/user/1).0.1
│ │   ├── github-url-from-username-repo[@1](/user/1).0.2
│ │   └── semver[@3](/user/3).0.1
│ ├─┬ request[@2](/user/2).30.0
│ │ ├── aws-sign2[@0](/user/0).5.0
│ │ ├── forever-agent[@0](/user/0).5.2
│ │ ├─┬ form-data[@0](/user/0).1.4
│ │ │ ├── async[@0](/user/0).9.0
│ │ │ └─┬ combined-stream[@0](/user/0).0.5
│ │ │   └── delayed-stream[@0](/user/0).0.5
│ │ ├─┬ hawk[@1](/user/1).0.0
│ │ │ ├── boom[@0](/user/0).4.2
│ │ │ ├── cryptiles[@0](/user/0).2.2
│ │ │ ├── hoek[@0](/user/0).9.1
│ │ │ └── sntp[@0](/user/0).2.4
│ │ ├─┬ http-signature[@0](/user/0).10.0
│ │ │ ├── asn1[@0](/user/0).1.11
│ │ │ ├── assert-plus[@0](/user/0).1.2
│ │ │ └── ctype[@0](/user/0).5.2
│ │ ├── json-stringify-safe[@5](/user/5).0.0
│ │ ├── mime[@1](/user/1).2.11
│ │ ├── node-uuid[@1](/user/1).4.1
│ │ ├── oauth-sign[@0](/user/0).3.0
│ │ ├── qs[@0](/user/0).6.6
│ │ ├─┬ tough-cookie[@0](/user/0).9.15
│ │ │ └── punycode[@1](/user/1).3.1
│ │ └── tunnel-agent[@0](/user/0).3.0
│ ├── retry[@0](/user/0).6.1
│ ├── rimraf[@2](/user/2).2.8
│ ├── semver[@2](/user/2).3.2
│ ├─┬ sha[@1](/user/1).2.4
│ │ └─┬ readable-stream[@1](/user/1).0.31
│ │   ├── core-util-is[@1](/user/1).0.1
│ │   ├── inherits[@2](/user/2).0.1
│ │   ├── isarray[@0](/user/0).0.1
│ │   └── string_decoder[@0](/user/0).10.31
│ ├── slide[@1](/user/1).1.5
│ ├── sorted-object[@1](/user/1).0.0
│ ├── tar[@1](/user/1).0.1
│ ├── text-table[@0](/user/0).2.0
│ ├── uid-number[@0](/user/0).0.5
│ └── which[@1](/user/1).0.5
└─┬ through2-map[@1](/user/1).4.0
  ├─┬ terminus[@1](/user/1).0.10
  │ ├─┬ readable-stream[@1](/user/1).0.31
  │ │ ├── core-util-is[@1](/user/1).0.1
  │ │ ├── inherits[@2](/user/2).0.1
  │ │ ├── isarray[@0](/user/0).0.1
  │ │ └── string_decoder[@0](/user/0).10.31
  │ └── xtend[@3](/user/3).0.0
  ├─┬ through2[@0](/user/0).5.1
  │ └─┬ readable-stream[@1](/user/1).0.31
  │   ├── core-util-is[@1](/user/1).0.1
  │   ├── inherits[@2](/user/2).0.1
  │   ├── isarray[@0](/user/0).0.1
  │   └── string_decoder[@0](/user/0).10.31
  └── xtend[@3](/user/3).0.0
1 回复

也出现同样问题,求解

/usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/init-package-json requires glob@’^4.0.2’ but will load npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/glob, npm WARN unmet dependency which is version 5.0.3 npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/read-package-json requires glob@’^4.0.2’ but will load npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/glob, npm WARN unmet dependency which is version 5.0.3 npm@2.9.0 /usr/local/lib/node_modules/npm

回到顶部