cnpm最近两天是炸了么???
发布于 1 个月前 作者 lzq920 1184 次浏览 来自 问答

image.png

11 回复

错误原因不是写的很清楚了么?你用的那个包炸了,因为它本身的问题,不是快递的问题

cnpm 加入缓存后应该说最近是前所未有的稳定,之前才是一直炸。这个显然是你安装的包自己的问题

@atian25 用npm安装就没有出现这个错误,我在想是不是内部的包关联的东西不一样,还是因为我package.json没有锁定版本引起的

@hyj1991 npm安装正常,cnpm安装就出现这个错误了,package.json没有锁定版本,会不会是这个问题?

给出复现方式呗

你是cnpm 命令行工具出错吗?如果是的话,可以使用 NPM,然后设置成cnpm仓库就行,我以前cnpm命令行安装一些包也时不时报错 image.png

不好说,要楼主给出 package.json 我们试试才知道。

不过看截图中的 core-js 上周确实是挂了,它们发包出问题了。

@atian25 这是我package.json的内容 到现在用cnpm安装的依赖,在构建的时候还是会报错

{
  "name": "cloud-console-manger",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve --mode development --open",
    "production": "vue-cli-service --mode production build",
    "test": "vue-cli-service --mode test build"
  },
  "dependencies": {
    "axios": "^0.18.0",
    "echarts": "^4.2.1",
    "element-ui": "^2.6.3",
    "moment": "^2.24.0",
    "v-charts": "^1.19.0",
    "v-viewer": "^1.4.0",
    "vue": "^2.6.10",
    "vue-router": "^3.0.2",
    "vue2-editor": "^2.6.6",
    "vuex": "^3.1.0",
    "vuex-persistedstate": "^2.5.4",
    "weex-editor": "^0.2.4"
  },
  "devDependencies": {
    "@vue/cli-plugin-babel": "^3.5.1",
    "@vue/cli-service": "^3.5.1",
    "vue-template-compiler": "^2.6.10"
  }
}

@zhhb 目前用npm好像是没问题的

@lzq920 试了下,无法复现

➜  abc cat package.json
{
  "name": "cloud-console-manger",
  "version": "0.1.0",
  "private": true,
  "scripts": {
    "serve": "vue-cli-service serve --mode development --open",
    "production": "vue-cli-service --mode production build",
    "test": "vue-cli-service --mode test build"
  },
  "dependencies": {
    "axios": "^0.18.0",
    "echarts": "^4.2.1",
    "element-ui": "^2.6.3",
    "moment": "^2.24.0",
    "v-charts": "^1.19.0",
    "v-viewer": "^1.4.0",
    "vue": "^2.6.10",
    "vue-router": "^3.0.2",
    "vue2-editor": "^2.6.6",
    "vuex": "^3.1.0",
    "vuex-persistedstate": "^2.5.4",
    "weex-editor": "^0.2.4"
  },
  "devDependencies": {
    "@vue/cli-plugin-babel": "^3.5.1",
    "@vue/cli-service": "^3.5.1",
    "vue-template-compiler": "^2.6.10"
  }
}
➜  abc cnpm i
✔ Installed 15 packages
✔ Linked 872 latest versions
[1/2] scripts.install @vue/cli-plugin-babel@3.5.1 › webpack@4.28.4 › watchpack@1.6.0 › chokidar@2.1.5 › fsevents@^1.2.7 run "node install", root: "/Users/tz/Workspaces/tmp/abc/node_modules/_fsevents@1.2.7@fsevents"
node-pre-gyp WARN Using request for node-pre-gyp https download
node-pre-gyp http GET https://cdn.npm.taobao.org/dist/fsevents/v1.2.7/fse-v1.2.7-node-v64-darwin-x64.tar.gz
node-pre-gyp http 200 https://cdn.npm.taobao.org/dist/fsevents/v1.2.7/fse-v1.2.7-node-v64-darwin-x64.tar.gz
[fsevents] Success: "/Users/tz/Workspaces/tmp/abc/node_modules/_fsevents@1.2.7@fsevents/lib/binding/Release/node-v64-darwin-x64/fse.node" is installed via remote
[1/2] scripts.install @vue/cli-plugin-babel@3.5.1 › webpack@4.28.4 › watchpack@1.6.0 › chokidar@2.1.5 › fsevents@^1.2.7 finished in 602ms
[2/2] scripts.install @vue/cli-service@3.5.2 › yorkie@^2.0.0 run "node bin/install.js", root: "/Users/tz/Workspaces/tmp/abc/node_modules/_yorkie@2.0.0@yorkie"
setting up Git hooks
can't find .git directory, skipping Git hooks installation
[2/2] scripts.install @vue/cli-service@3.5.2 › yorkie@^2.0.0 finished in 95ms
✔ Run 2 scripts
Recently updated (since 2019-03-20): 32 packages (detail see file /Users/tz/Workspaces/tmp/abc/node_modules/.recently_updates.txt)
  Today:
    → @vue/cli-plugin-babel@3.5.1 › @vue/babel-preset-app@^3.5.1(3.5.2) (10:44:28)
    → @vue/cli-service@^3.5.1(3.5.2) (10:44:28)
    → @vue/cli-plugin-babel@3.5.1 › @vue/babel-preset-app@3.5.2 › @babel/plugin-transform-runtime@7.4.0 › semver@^5.5.1(5.7.0) (07:25:47)
    → @vue/cli-plugin-babel@3.5.1 › @vue/cli-shared-utils@3.5.1 › joi@14.3.1 › hoek@6.x.x(6.1.3) (08:32:16)
    → @vue/cli-service@3.5.2 › globby@9.1.0 › @types/glob@7.1.1 › @types/node@*(11.12.0) (04:23:45)
✔ All packages installed (984 packages installed from npm registry, used 9s(network 8s), speed 246.86kB/s, json 887(1.85MB), tarball 0B)

@atian25 不大清楚。。我这边是有这个问题的。。

回到顶部