npm淘宝源对于peerDependencies的异常行为
发布于 24 天前 作者 takayama-lily 445 次浏览 来自 问答

我使用 npm i ws 安装ws库 淘宝源会自动安装peerDependencies里的bufferutilutf-8-validate模块 由于是addon模块,有些环境下会直接导致安装失败。 换成官方源就正常,不会自动安装这两个模块。

按理说只是换个源,不应该出现行为不一致。 一头雾水。(npm版本是7.22.0)

1 回复

这也是为什么安装firefox要从官网 http://ftp.mozilla.org/pub/firefox/releases/ 下载的原因 按理说,firefox从哪里下载都一样

回到顶部