Node.js 22 发布,支持 require() 同步 ESM 、原生支持 WebSocket 客户端、内置glob 和 globSync
发布于 22 天前 作者 npmstudy 530 次浏览 来自 分享

昨日,Node.js 官方博客正式宣布 Node.js 22 的发布!新版本亮点包括 require() ES 模块、WebSocket 客户端、V8 JavaScript 引擎的更新等!

Node.js 22 将在 10 月进入长期支持 (LTS),但在此之前,它将是接下来六个月的 Current 发布版。下面让我们一起来探索此最新发布提供的新特性和优势,并评估它们对您应用程序的潜在影响。

该项目在许多领域继续取得进展,许多新特性和修复程序流入现有的 LTS 发布版。变更日志中概述的 Node.js 22 的变更仅代表了自上一主要发布以来特性和工作的一小部分。

要下载 Node.js 22.0.0,请访问 Node.js 官网,您可以在其中找到发布帖子,其中包含了此发布中包含的完整提交列表。

显著变更

V8 更新至 12.4 版本

V8 12.4 版本发布包括了新特性,如 WebAssembly 垃圾回收、Array.fromAsync、Set 方法和 迭代器助手。

Maglev

V8 的 Maglev 编译器现在在支持的架构上默认启用。Maglev 提高了短期 CLI 程序的性能。

支持 require() 同步 ESM

此发布在标志 --experimental-require-module 下添加了对同步 ESM 图的 require() 支持。

如果启用了 --experimental-require-module,并且 require() 加载的 ECMAScript 模块满足以下要求:

明确标记为 ES 模块,在最近的 package.json 中有一个 “type”: “module” 字段或一个 .mjs 扩展名。 完全同步(不包含顶层 await)。 require() 将加载所请求的模块作为 ES 模块,并返回模块名称空间对象。在这种情况下,它类似于动态的 import(),但是是同步运行并直接返回名称空间对象。 我们打算最终在将来默认启用 require(esm),无需标志。

运行 package.json 脚本

Node.js 22 包括了一个新实验特性,用于使用 cli 标志 node --run <script-in-package-json> 执行 package.json 中的脚本。

它还支持 node --run test,该命令执行 package.json 脚本中的测试命令。

流默认高水位标记

将流的默认高水位标记从 16KiB 增加到 64KiB。这在略微增加内存使用的情况下,全面提高了性能。建议在内存敏感环境中的用户明确设置 setDefaultHighWaterMark。

观察模式 (node --watch)

从这个发布开始,观察模式被认为稳定。当处于观察模式时,被观察文件的更改会导致 Node.js 进程重新启动。

WebSocket

之前在标志 --experimental-websocket 后的浏览器兼容 WebSocket 实现将默认启用。 这为 Node.js 提供了一个无需外部依赖的 WebSocket 客户端。

glob 和 globSync

此发布为 node:fs 模块添加了 glob 和 globSync 函数,用于模式匹配。 开发者现在可以利用这些函数根据指定的模式匹配文件路径。

提高 AbortSignal 创建的性能

此发布提高了创建 AbortSignal 实例的效率,从而显著提高了 fetch 和测试运行器的性能。

行动号召

试试新的 Node.js 22 发布版!我们总是乐于听到您的反馈。使用 Node.js 22 测试您的应用程序和模块有助于确保您的项目与最新的 Node.js 更改和特性的未来兼容性。

另外值得注意的是,Node.js 18 将在 2025 年 4 月结束生命周期,所以我们建议您开始计划升级到 Node.js 20 (LTS) 或 Node.js 22 (即将成为 LTS)。

参考链接:https://nodejs.org/en/blog/announcements/v22-release-announce

2 回复

require esmodule nb,感谢张秋怡大佬!

回到顶部